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What's In this Package
This package contains the MOVIE program files and help files.    The following    is a listing of   
the files installed with MOVIE:
FILE.DLL Library file.
HOOKLIB.DLL Library file.
MOVIE.EXE Program file.
MOVIE.HLP Windows help file.
BALLOON.MOV Movie of balloon.
BOUNCE.MOV Movie of bouncing ball simulation.
VOYAGER.MOV Movie file of map data in demo movie.
README.TXT Information about MOVIE.
REGISTER.TXT Sample registration for MOVIE.
Related Topics:

Requirements



Requirements
The MOVIE animation tool requires Windows 3.0 or 3.1.      
DISK SPACE:
The MOVIE program and help files require approximately 500 KB of free hard disk space.      
The .MOV files    are not required for MOVIE to run.    These files can be removed after 
installed to reduce disk space.



License Agreement
0. This License Agreement applies to Lantern Corporation's MOVIE software (herein referred to as "Program") 

between licensee (herein referred to as "you") and Lantern Corporation (herein referred to as "Lantern").
Registration of Program:
1. This Program is Shareware.    It is not free.    It is distributed freely for the purpose of evaluation by users for

a period of 30 days.    If you find this Program useful, you are required to register it with Lantern. This 
entitles you to certain benefits outlined below.

2. Registration of the Program by you will include the following:
Registration Certificate.
Free upgrade of MOVIE.
Hard copy of Program documentation and instructions including application notes for use with 
MOVIE.
Technical Support
List of public domain movies for use with Program.
Update notices.

These are described in more detail in    Registration Benefits.
3. Registration requires a written registration (or similar correspondence) contained herein as 

"REGISTRATION", to be sent by you to Lantern at the following address: Lantern Corporation, 63 Ridgemoor
Drive, Clayton, MO    63105, along with the enclosure of a registration fee of $49 in US dollars.    
Registration of the Program to you will not occur until Lantern has received both the registration notice and
registration fee.    

Copying and Distribution:
4. You may copy and distribute the Program as you receive it, in any medium, provided that you 

conspicuously and appropriately publish on each copy an appropriate copyright notice and disclaimer of 
warranty; keep intact all the notices that refer to this MOVIE License, and to the absence of any warranty; 
and give any other recipients of the Program a copy of this MOVIE License along with the Program.

5. A nominal fee not to exceed $5 for expenses, handling and reproduction costs can be charged for 
distribution of this Program.

Warranty:
7. This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even 

the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.        This MOVIE License
explicitly excludes any movie files (*.MOV) distributed with the Program.    All movies are subject to the 
restrictions applied by the owners.    You should contact the owner of the movie for the appropriate 
distribution rights.



Registration
Please make your payment of $49 in US dollars payable to: Lantern Corporation.    Please do not send cash.
Name: __________________________________ Company: ___________________________
Address: ____________________________________________________________________
City: ___________________________State:    _____        Zip: ____________________________
Phone:__________________________FAX:_________________________________________
Where did you hear about MOVIE? 
 _____________________________________________________________________________
Signed: ______________________________________________    Date:    _________________ 
Send to: Lantern Corporation, 63 Ridgemoor Drive, Clayton, MO 63105.
Print this topic to use this registration form.



Registration Benefits
Upon registration of MOVIE, you will receive:
Registration Certificate
This certificate will show that you are a registered user of MOVIE and allow you to obtain 
technical support from Lantern Corporation.
Upgrade of MOVIE
The upgrade version of MOVIE contains a script feature that allows you to play and organize 
individual movie files into longer more complicated movies.    The scripts allow you to:    play 
movie files with command line parameters, insert pauses, exit the movie program, loop the 
entire script, save images on the screen, and play other script files from within the script.    
Program Documentation and Application Notes
The application notes include how to use MOVIE with popular software such as Microsoft 
Excel, Voyager, fractal programs, and drawing programs.    Using Windows 3.1 and using 
MOVIE with DOS applications is explained, along with tips and tricks on creating 
presentations and slide shows.
Technical Support
Technical support will be provided from 9:00am to 5:00pm central time, or via Compuserve.
List of Public Domain Movies
Lantern Corporation will provide a list of movies available and where to get them.
Update Notices
Lantern Corporation is constantly developing its products to provide its users with the best 
possible product.    As a registered user, you will receive notices about MOVIE updates.



Viewing the Demonstration Movie
This version of MOVIE contains demonstration movies that show some of the uses of MOVIE.  
To view these movies refer to Open in the File menu.
In addition, demonstration movies require your monitor to display 16 colors.    Monitors set in
256 mode will not display the movies.    For information about movies and devices, see 
Memory and Devices.



Components
The MOVIE application has three components: the MOVIE icon, a Remote Control, and a 
Display Screen. 

MOVIE Icon
Display Screen
Remote Control



MOVIE Icon

The MOVIE icon represents the program in the Windows Program Manager.    This icon is used
to start MOVIE -- the same as in other applications -- by double clicking on the icon.    After 
MOVIE is started the icon appears at the bottom of the screen.    Double clicking on this icon 
opens MOVIE's display screen.    



Display Screen

The display screen displays the animated sequences produced by MOVIE.    It is analogous to 
a TV screen.    The display screen also contains MOVIE's menu.    You access the menu from 
the display screen by clicking anywhere on the display screen 



Remote Control

Playback Mode Record Mode
The Remote Control unit contains a subset of MOVIE's control functions.    It serves the same 
purpose as a Remote Control unit of a VCR in that it controls both recording and playing 
functions.    The remote changes modes, however, depending if MOVIE is playing or recording
a movie.    Both modes are shown above.
The Remote Control can be displayed by selecting Remote Control from the Control menu 
or by pressing R on the keyboard when MOVIE is active.    In addition, command line options 
can be used to automatically display the remote when MOVIE is started.
Click on the following for help about that feature:
Open... Rec... Play > Loop Hold
Snap! Stop. Rel Auto Frame
Related Topics:

Adjusting the Speed
Displaying the Current Frame
Moving Frame by Frame



Adjusting the Speed
During playback, you can control the speed of the movie by adjusting the scroll bar.    Moving
it to the left causes    the movie to play slower, moving it to the right causes the movie to 
play faster.



Displaying the Current Frame
The remote control displays the current frame below and to the right of the scroll bar.    You 
can use this to locate specific frames or to find the total number of frames in a movie.



Moving Frame by Frame
Also using the remote, you can display the movie frame by frame.    The frame bar located 
below the Play> and Stop buttons of the remote control displays the number of frames 
contained within the current movie.    By using the arrow keys or the scroll bar, you can move
through the movie frame by frame.
Refer to the Frame Menu for additional frame commands.



Making a Movie
The following outlines the steps in making a movie.    Detailed instructions follow:
1. Start MOVIE.

Start an application to record with.
Without closing the previous application, start MOVIE and press R on the keyboard to 

display the remote control.
2. Select the area to capture (capture area).

Using the remote, click on Record...
Give a file name using .MOV as the extension.
Click on OK.
Place the clapboard on the application to record.

3. Create frames of    the movie.
Use Ctrl+Alt+F9 or click on Snap! on the remote to create frames.

4. Stop recording.
When the frames are recorded, click on Stop on the remote.

5. Playback the movie.
Using the remote, click on Play> to view the movie.

For More Information:
Starting Movie
Selecting a Capture Area
Creating Frames
Playing the Movie



Starting Movie
To start MOVIE, double click on the MOVIE icon causing the icon to be displayed at the 
bottom of the screen.    



Selecting a Capture Area
Without closing MOVIE, open an application that you would like to use with MOVIE.    

Use Ctrl+Esc to switch to MOVIE.    
Select Record...    from the File menu or the remote control.

MOVIE requires that you give the filename of the movie before you create it.      You must use 
a *.MOV extension.    When you have entered the movie's filename, the mouse cursor 
becomes a clapboard with the arm up.
For More Information:

To capture a window:
To capture an area:
Moving and Resizing Windows



To capture a window:
Place the clapboard onto the window you want to capture and press the left mouse 

button.    
MOVIE defines a window to be any area encompassed by a solid line.    A border will appear 
along the edges of the window to indicate the capture area.    
If MOVIE did not select the area you want to capture:

Switch to MOVIE and select New... from the File menu or remote control.
Select Record... from the File menu or remote control.

You can record over the file you just created by selecting it.    Try using the capture area 
method to define your capture area.



To capture an area:
Place the clapboard in the upper right corner of the area to capture.    
Hold down the left mouse button and drag the clapboard to the bottom left corner of the 

area to capture.    
This causes a selection box to appear around the area.    Release the mouse button when the
area is within the selection box.



Moving and Resizing Windows
You can move the application's windows once you have declared a capture area by turning 
on--indicated by a check mark next to the item--the Window Relative menu item under the
Options menu.    
You should not resize an application once a capture area is declared because the capture 
area will NOT resize itself.    If you need to resize the application, declare a new capture area 
using the application's new size.



Creating Frames
After a capture area is selected, you can record a frame of    the movie at any time by:

clicking the Right mouse button over the MOVIE icon 
or 
pressing Ctrl+Alt+F9.    
or
pressing Snap! on the remote control.

When the frame is recorded the selection border briefly appears around the selected area or 
window and the movie reels of the icon turn. 
Make changes to the capture area then record the next frame.    Continue this process until 
several frames have been recorded.    
Related Topics:

Stopping the Recording
Automatic Frame Captures



Stopping the Recording
When all the frames have been recorded:

Switch to MOVIE using Ctrl+Esc.
Select Stop from the Control menu or from the remote control.



Automatic Frame Captures
Several options for automating the process of creating frames are available using the Auto 
Events... command under the Options menu.    Once you have selected an option select 
Auto Record from the Options menu to start auto recording.    To stop auto recording, 
unselect Auto Record.



Playing the Movie
To playback the movie:

Select Play > from the File menu or from the remote control.    
If no MOVIE is loaded, use Open.. from the File menu or remote control.

This will create a display screen that will play the movie. When you open a movie, it will 
open the display screen using the movie's original size. 
To expand the window size, use the window boundaries.      As you size the window the movie
will continue to play in its recorded size.    You can use the Stretch option in the Control 
menu to size the movie to MOVIE's window boundaries.    However, this will effect the 
performance of MOVIE.    Movies play best when viewed at their original size (the size they 
were recorded in).
You can maximize MOVIE's window to cause the current movie to play in the center of the 
screen.    This is an effective way to play demonstrations or presentations because no 
window boundaries are present.    



File Menu
The file menu contains menu items that control the opening and recording of movie files and
the playing of the demonstration movie.

New
Open...
Record...
Exit



New
New clears the current movie file from memory.    Use this item if    more memory is required 
for another application.



Open...
Open... displays a dialog box showing existing MOVIE animation files for playing.    Movie 
files have the extension *.MOV.      From the Open... dialog box    select the movie to open.    
When a movie is opened, it immediately begins playing.



Record...
Record... will clear the current MOVIE and allow to record a new movie.
Before you record a movie, you will be prompted to enter the filename.    You can enter a 
new filename or record over an existing file by entering its filename.
When you have entered a filename, the mouse will change to a clapboard.    Next, designate 
a capture area to record. 



Exit
This will exit MOVIE and remove any movies from memory.



Control Menu
The control menu contains menu items used for playing or recording a movie.

Play >
Snap
Stop
Remote Control



Play >
To play a movie, you must first have a movie loaded either by opening a movie using the 
Open... command, or have recorded a movie using the Record... command.
Once a movie is loaded it will automatically begin playing.    Once you have recorded a 
movie, simply press Play > and the movie will begin. 



Snap
Snap will record a frame of the movie.    This is equivalent to pressing Ctrl+Alt+F9 or 
clicking on the MOVIE icon with the right mouse button.
When the frame is recorded,    a border briefly appears around the selected area or window 
and the reels of the MOVIE icon turn.



Stop
Stop will end the recording or stop the playback.



Remote Control
Remote Control toggles the remote control display on or off.    If the remote is on, a check 
mark will appear beside this menu item.
Using the Remote Control



Frame Menu
The Frame menu allows you to move through the movie frame by frame or to jump to the 
beginning or end.    When the movie is in playback mode you can use the following Menu 
Items or Keystrokes to execute where to move within the movie:
Menu Item Keystroke Moves to
First Home First Frame
Back PageUp Previous Frame
Next PageDn Next Frame
Last End Last Frame
The remote control provides the frame number with the movie file.



Options Menu
The Options menu allows you to change the modes of operation of MOVIE.    This includes 
sizing the display screen, loop the movies playback, insert a pause between playbacks, 
display a remote control, and cause the capture area to be relative to a window.    The 
default mode of these options can also be set using the Command Line Options.

Loop
Hold
Movie Size
Window Relative
Auto Record
Auto Events...
Record Monochrome
Stretch



Loop
Loop mode will play the move as a continuous loop.    After the last frame of the movie is 
played, the movie will start again from the beginning.



Hold
Hold will pause the movie between loops for one second.



Movie Size
Movie Size will resize the display screen to the original recording.    This will produce a 
significant speed increase over expanded or contracted display screens during playback.



Window Relative
The Window Relative option causes the selection area to "stick" to the application--the 
selection area stays relative to the window.    This allows the application and the selection 
area to be moved from one location to another.
When this option is off (the default mode), the selection area does not move with the 
window it was declared in.    Instead, the selection area remains in a fixed position on the 
screen.    
Related Topics:

Sizing an Application



Sizing an Application
You should not resize an application once a capture area is declared because the capture 
area will NOT resize itself.    If you need to resize the application, declare a new capture area 
using the application's new size.



Auto Record
Auto Record snaps frames automatically, depending on the event selected in using the 
Auto Events... command.



Auto Events...
Auto Events... can initiate the capturing of a frame depending on the selections made in 
the dialog box.    The auto events can also be set using the Command Line Options.
Auto Events Dialog Box:

The following options are available:
Before paints Snaps before a paint occurs.
After paints Snaps after a paint occurs.
Keystrokes Keystrokes are sent to the window.
Mouse Clicks Mouse clicks are set to the window.
Every Second A capture will occur every n seconds



Record Monochrome
This menu command will record the movie as monochrome.    Use this option if you are 
having trouble displaying a movie using other monitors.



Stretch
This menu item will cause the current movie to stretch to the borders of the MOVIE window, 
or if the MOVIE window is maximized, will cause the movie to stretch over the entire screen.  
This menu item toggles off and on.



Help Menu
Index
Help on Help
About Movie...



Index
This menu item will show this help file.



Help on Help
This menu item will start the Windows help file for using help.



About Movie...
This menu item will give information about MOVIE .    The following is the About Movie... 
dialog box:



Using Motion
Motion can be very effective in presentations for capturing your audience's attention.    You 
accomplish motion by snapping a frame, moving an object and then snapping another 
frame.    There are, however, some guidelines to use when creating motion.
The larger the object, the less the object should be moved between frames.    This is because
larger objects take longer to redraw and their movement is more noticeable.    Smaller 
objects can be moved a greater distance between frames.    They take less time to redraw 
and their movement is less noticeable.
Experimentation and practice are the best methods in creating motion.    Using different tools
and movement will effect the results.    As you work with different techniques you will find 
those that give the best effects and results.



Editing Movies
Upon registering MOVIE, you will receive an upgrade of MOVIE.    Using this upgrade you can 
write scripts that allow you to link separate movie files together and create longer more 
complicated movies.    
In this version, however, editing is accomplished by running two copies of MOVIE--one to 
play a movie and the other to record.    This process allows you to combine several movies 
from different sources, splice frames between movies, and to create longer more 
complicated movies.    If you are editing acrross movie files (using frames from different 
movies) you should organize your movie files first.    Inaddition, there are considerations 
about the capture area you need to decide in advance.    
For More Information:

Getting Started
Procedure



Getting Started 
Before you get started, it is helpful to create a script that will outline each scene.      Scripts 
are useful to help organize longer more complicated movies.    The script should contain 
information about what will be presented on the screen, any motion or movement between 
objects, and any text that will appear.    You should create a separate movie file for each 
scene in the script.
A good way to organize a long movie is to create a subdirectory that will contain all the 
movie files.    This neatly keeps all scenes in the same location.    
When you create your scenes, it is not necessary to duplicate the frames for each picture in 
order to control how long a picture is displayed.    You can do this when combining the 
movies.    Therefore, you only need one frame for each picture in your scene.
Selecting a Capture Area
You can play a movie two ways: with MOVIE's window border present playing the movie in its
original or custom size; or with MOVIE maximized so that the movie plays in the middle of 
the screen.    If you are editing frames all the same size, use MOVIE's window border to set 
the capture area.    If you are editing frames that are different sizes, you can maximize 
MOVIE and declare an area in the center of the screen as the capture area.    
In addition, you can also delcare an area within MOVIE's borders, or you can maximize 
MOVIE and delclare the entire screen as the capture area.    Choose the method that suits 
your needs.    If you don't like the results, use a different method.    Practice and 
experiementation are the best methods.



Procedure
The procedure for editing or combining movies uses two copies of MOVIE running 
simultaneously.    One copy of MOVIE plays each frame, while the other copies the first's 
display screen.    It may be helpful to do a "run-through" of    the scenes to find any problems 
before you begin recording.

Open two copies of MOVIE.
Using one copy of MOVIE, Open... the first frame.
Using the second copy of MOVIE,    start Record...    and select the capture area using the

guidelines above.
Use the remote to display the frames using Ctrl+Alt+F9 to copy each frame into the 

new movie.
Tips
When you finish a long movie, it may be more efficient to edit (adding more frames, 
removing frames) the newly created movie using the procedure above.    This reduces the 
number of files to be loaded to one and reduces the number of additional errors that could 
be created by redoing the entire movie.
It may be helpful to display both remote controls.    This will allow you to see the number of 
frames that you are adding to the new movie.
It may be necessary to use the Switch To... command in MOVIE to start the second copy of 
MOVIE if your display screen is maximized.
By using the PageDn key to go to the next frame in the movie you are recording from, and 
Ctrl+Alt+F9 to snap a frame, you can use a macro recorder to make the editing easier.    
Windows comes with Recorder, a program that allows you to assign a series of keystrokes 
to a single key.    



Command Line Options
The Windows Program Manager allows typing optional command line parameters.    These 
can be used to start one particular MOVIE file or to set the default configuration of MOVIE.    

Syntax



Syntax
The syntax for the command line is:

MOVIE    [ /options ]          [filename.mov]
options:
The options need to start with a /.    To place more than one option, you do not need to use a 
space between each option.    For example:    /ZRA. 

Z Set the window to the MOVIE's original size.    This is required for the 
Fn, Sn and P options.

R Displays the remote control.
L Enable the Loop option.
H Enable the Hold option.
Sn Speed of playback where n equals 0 for fastest and 1000 for slowest.
Fn Frame to display where n equals the frame number.
W Enable the Window Relative option.
M Maximizes MOVIE's window.
P(x,y,w,h) Window position in 0-10000 units.

x Distance between left border and left edge of screen.
y Distance between upper border nad edge of screen.
w Width of MOVIE window.
h Height of MOVIE window.

filename.mov
This is the filename of the movie to play when MOVIE is started.
EXAMPLES:
MOVIE /ZL BALLOON.MOV
Plays and loops the movie BALLOON.
MOVIE /ZLHS500 BALLOON.MOV
Plays and loops at medium speed the movie BALLOON with a pause between loops.
MOVIE /ZF12 BALLOON.MOV
Opens the movie BALLOON and displays frame 12.



Memory and Devices
Memory
Movies consume large amounts of memory, both in RAM and on the hard disk.    MOVIE uses 
two different compression schemes to reduce memory requirements.    You can manage your 
movie's size by either the size of the capture area or the number of frames.    The greater the
number of frames then the smaller the capture size should be.
In addition, certain subject matter will increase the size of your movie.    These are:    radical 
changes in the composition of the screen from one frame to another, gradients, and rapid 
movement of large objects.
Devices
Movies will play with some limitation on different display devices than the ones they were 
created on.    In general, you can display any movie on any monitor as long as the number of
colors are the same.    This means that a movie made on 16 colors will NOT play on a monitor
using 256 colors or visa versa.    
In addition, you may also incur some problems displaying movies using different graphic 
arrays.    For example, movie created on some super VGA monitors will not play on CGA 
monitors.    The best rule to anticipate problems is to create a small movie of a few frames 
and test on the graphic arrays you are using.



Playback Mode Record Mode
Open... Rec... Play > Loop Hold
Snap! Stop. Rel Auto Frame
Select an option to view that help screen or click the right mouse button to remove this 
screen.



MOVIE's Menu.


